ti-enxame.com

Como atualizar o mod_wsgi para a última versão no Ubuntu 10.04?

Meu servidor Ubuntu tem esta versão instalada:

# dpkg -l | grep wsgi
ii  libapache2-mod-wsgi  2.8-2ubuntu1  Python WSGI adapter module for Apache

Como posso obter o última versão 3. ?

4
webjunkie

Baixe e compile. Há um bom README em seu pacote fonte. Mas você pode começar instalando build-essential o sistema básico para compilar, então é só seguir o README

2
LassePoulsen

Sudo apt-get build-dep libapache2-mod-wsgi

E então você pode construir a partir da fonte lendo o readme

1
sagarchalise

O Debian tem libapache2-mod-wsgi , mas isto não funcionará no Ubuntu 10.04 porque depende do libpython2.7 para o qual não há nenhum pacote para o 10.04.

Eu baixei a fonte de aqui :

$ wget http://modwsgi.googlecode.com/files/mod_wsgi-3.3.tar.gz

Então só

./configure
make
Sudo make install
1
David Xia

Eu tinha mod_wsgi instalado para python 2.7. Eu executei o comando abaixo para desinstalar o 2.7 e instalar o 3.6 (my python version).

Sudo apt-get install libapache2-mod-wsgi
0
esafresa

O que funcionou para mim foi executar isso:

Sudo aptitude install libapache2-mod-wsgi
0
user434136