ti-enxame.com

Módulo de menu não aparecendo / funcionando com ACL

Eu tenho um menu do usuário, ou seja, X e é atribuído a um módulo.

Eu também criei um grupo de usuários e um nível de acesso de usuário. Em seguida, designei o nível de acesso do usuário ao grupo de usuários que criei, ou seja, Y. No entanto, quando atribuo o nível de acesso do usuário ao módulo, o módulo não é mostrado para mim (em uma conta que eu criei e eu atribuiu o grupo de usuários a ele).

Onde eu errei? Obrigado!

2
alinisme

Se você não mexeu com nada mais profundo e assumindo que é uma instalação casual do joomla com suas adições à ACL, é definitivamente algo que você não fez corretamente ou ignorou ao configurar seu grupo de usuários e nível de acesso.

Pode ser qualquer combinação de se o seu grupo de usuários é ou não filho de outro grupo de usuários e que, embora o grupo de usuários registrado tenha acesso ao seu Nível de Acesso Personalizado, o seu grupo de usuários personalizado não. Adicione à mistura que os itens de menu do seu menu também podem ter configurações de ACL e, dependendo do layout do módulo, o módulo não será exibido, se não houver acesso ao seu conteúdo.

Dê um passo atrás no site e leia um pouco a documentação sobre a implementação do ACL no Joomla, a fim de obter uma melhor compreensão.

Eu sugeriria iniciar sua experimentação com o Joomla ACL lentamente, fazendo pequenas alterações e testando o que está funcionando e por quê, pois pode ser realmente confuso e facilmente um site pode ficar confuso.

2
FFrewin