ti-enxame.com

Android alterar a versão do SDK no Eclipse? Não é possível resolver o destino Android-x

Desenvolvi uma aplicação Android no SDK 2.1. Desde então, reinstalei o Eclipse/Android SDK; com a nova instalação, desejo 'atualizar' a dependência do Android para o SDK 2.2 (porque eu não quero o 2.1 instalado na minha máquina) .É possível? Estou recebendo o seguinte erro do Eclipse:

[2010-08-31 18:18:32 - AndroidApplication] Unable to resolve target 'Android-7'
34
wuntee

Se você estiver usando o Eclipse, poderá abrir default.properties na área de trabalho e altere o destino do projeto para o novo sdk (target=Android-8 para 2.2). Eu acidentalmente selecionei o 1,5 sdk para a minha versão e não o peguei muito mais tarde, mas atualizá-lo e reiniciar o Eclipse pareciam ter funcionado.

60
fufux

vá para as propriedades do projeto e altere o destino de 7 para 8, altere o destino em Android manifesto e também vá para as propriedades do projeto clicando com o botão direito do mouse no projeto e escolha o destino

16
Ravindra singh

Isso pode acontecer quando você importa por engano um projeto Android para a área de trabalho do Eclipse como um projeto Java. Java. A solução neste caso: a solução neste caso: exclua o projeto da área de trabalho em o Package Explorer e, em seguida, vá para Arquivo -> Importar -> Android -> Existente Android na área de trabalho.

8
1''

Eu enfrentei o mesmo problema e o fiz funcionar.

Eu acho que é porque quando você importa um projeto, o destino da compilação não está definido nas propriedades do projeto, que é o padrão do valor usado no arquivo de manifesto. Provavelmente, você já instalou uma API posterior Android API com seu SDK.

A solução é habilitar o destino da compilação no nível da API instalado (mas mantenha o suporte mínimo à API, conforme especificado no arquivo de manifesto). Para fazer isso, nas propriedades do projeto, acesse o Android e, em "Alvo de Construção do Projeto", escolha um nome de destino.

5
terry noah

No Build: v22.6.2-1085508 ADT, você precisa adicionar (selecione Android 4.4.2))

Vá para projeto -> propriedades -> Android (este é o segundo na ordem de itens listados leftPanel) e no TargetPanel Project Build Target, selecione Android 4.4.2 como Target target e aplique alterações). reconstruir o espaço de trabalho.

No meu caso incapaz de resolver o destino 'Android-17' O Eclipse estava sendo mostrado como erro de compilação e no código: import Java.util.HashMap não estava sendo referenciado.

3
vimal krishna

Esse problema ocorre devido ao caminho, portanto, você precisa criar o caminho usando as etapas a seguir

Ir para o projeto -----> Clique com o botão direito do mouse em Nome do projeto ----> properties ----> clique em Than Caminho de criação do Java opção que ---> clique em Android 4.2.2 ----> Ok

2
KaranR

Vá para projeto -> propriedades -> (na caixa de diálogo que abre goto Java) e, em ordem e exportação, selecione Android 4.1 (seu nova versão) e selecione dependências.

1
abdulqadeer