ti-enxame.com

Como você nomearia funções de importação e exportação em Java?

Eu tenho uma classe Java classe que lida com importação e exportação de dados. Começou como um simples

private void export() {
}
private void import() {
}

Obviamente, escrevi a exportação primeiro, confirmei e depois passei a escrever a importação. Mas importar é uma palavra-chave em Java - Não posso usar isso como um nome de função. Então, volto e renomeio os dois métodos. Geralmente acabo com

private void doExport() {
}
private void doImport() {
}

o que é feio e parece artificial. O que você acha desses nomes? Tem alguma sugestão melhor?

Nota: Estou perguntando agora, porque já aconteceu três vezes e essa palavra-chave está ficando muito chata.

6
configurator

Eu preferiria algo assim:

private void importData(){}
private void exportData(){}

Se agora você deseja usar esta classe como uma API, você pode fazer algo assim:

dataUtil.importData();

Com o CodeCompletion do IDE, as diferenças são mais visíveis se esses métodos não começarem da mesma maneira.

4
ckuetbach