ti-enxame.com

Qual é a versão máxima do PHP que o Joomla 1.5 será executado?

Eu tenho um cliente com um antigo Joomla 1.5 que eles não querem atualizar este ano, mas o Host deles quer atualizar o servidor. Qual é a versão máxima do php que o Joomla 1.5 irá executar, em vez do min listado?

http://www.joomla.org/technical-requirements.html#footnote-1xPHP
Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

Seria executado ok em 5.3.10? Eu acho que ele quebraria na versão 5.4, mas acho difícil construir uma máquina de teste com versões antigas para testar. Então, mais perguntas da experiência.

obrigado

4
tristanbailey

Se você estiver executando o Joomla 1.5.14 ou abaixo , deverá seguir o PHP 5.2, pois pode haver algumas funções e/ou trechos de código que podem não funcionar em PHP 5.3

No entanto, se você estiver executando o Joomla 1.5.15 ou acima , você deve estar bem com a atualização para PHP 5.3. Se você estiver usando a biblioteca OpenID, isso não será compatível com PHP 5.3 e, portanto, você precisará encontrar uma alternativa ou ficar com PHP 5.2

Para obter mais informações sobre quais versões do PHP, MySQL e Apache, consulte o Requisitos técnicos

Eu sugiro que você atualize para o Joomla 1.5.26, que é a versão mais recente da série 1.5.

Espero que isto ajude

5
Lodder

Estou executando um site Joomla 1.5.26 ao lado de um novo site J3 em construção na mesma instalação PHP. O site J1.5 está funcionando perfeitamente em PHP = 5.6 sem nenhuma alteração, o site J1.5 é um site muito simples, com apenas algumas extensões.

4
biltong

Confirmo o Joomla 1.5.24 rodando em PHP 5.5.9-1ubuntu4.17. O PHP-FPM foi instalado com o apt. O servidor da Web é nginx. Todos os recursos parecem estar funcionando sem problemas.

3
Egeshi