ti-enxame.com

Pesquisa inteligente retorna 500 erros internos

Não consigo descobrir como fazer o Smart Search funcionar. Acredito que o habilitei adequadamente e tenho um pequeno conjunto de amostras indexado. Mas sempre que digito uma pesquisa, recebo um erro interno de 500. Os logs do Apache mostram:

"GET/component/Finder/search? Q = not & Itemid = 4816 HTTP/1.1" 500 31 " https://www.mysite.com/knowledge-base " "Mozilla/5.0 (Windows NT 10.0 ; Win64; x64) porta AppleWebKit/537.36 (KHTML, como Gecko) Chrome/60.0.3112.113 Safari/537.36 ": 443

Tentei verificar as permissões nas pastas e qualquer outra coisa que possa estar bloqueando esta pesquisa (como as Ferramentas administrativas). Sem sorte Alguma idéia de como eu posso depurar ainda mais isso?

1
Tom

Habilite o relatório de erros no site (altere-o de "Nenhum" para "Máximo" nas configurações do Joomla) e verifique a página. Você verá o erro real.

Normalmente, esses erros fatais são causados ​​por um plug-in não básico, pois a pesquisa inteligente principal não retorna nenhum erro.

1
itoctopus

Depois de tentar habilitar todas as configurações de depuração possíveis, ele nunca mostrou os detalhes do problema. Apenas um "erro de sintaxe".

No entanto, acabou sendo algo simples. Eu precisava de um item de menu.

O documentação de início rápido parecia sugerir que você poderia configurar uma interface de módulo ou de componente. Eu fiz apenas a interface do módulo.

Deve ser algo com o meu ambiente, difícil de acreditar que um erro de sintaxe seja mostrado aqui.

1
Tom