ti-enxame.com

Visão geral da atualização do 2.5 para o 3.x

Isso é algo que me interessa há algum tempo, considerando algumas coisas.

Quão bem a atualização de "um clique" vai melhorar antes da EdC do Joomla! 2,5?

No momento, temos uma taxa de sucesso muito baixa na atualização do 2.5, existem muitos problemas de compatibilidade que não são resolvidos apenas com a atualização e exigem algumas edições manuais para concluir o processo na maioria das vezes (problemas com JHTML são os mais comuns). Vejo).

Agora eu digo "problemas", mas apenas quero dizer que, após a atualização, as coisas não funcionam como pretendido, isso não significa que o componente "atualização" está quebrado.

Eu olhei em volta, mas só encontrei o seguinte:

http://docs.joomla.org/Joomla!_CMS_versions

http://developer.joomla.org/cms/roadmap.html

O primeiro afirma que, em dezembro de 2014, o suporte ao 2.5 será descartado. O segundo indica o roteiro para 3.x. No entanto, no momento, é muito difícil fazer upgrade do 2.5, quanto maior o site, mais difícil é. Não sei ao certo o que faz com que alguns tenham sucesso e outros não, na maioria dos casos, não podemos isolá-lo diretamente para extensões de terceiros (quebras do gerenciador de extensões e tabelas ausentes, e o gerenciador de extensões é onde você corrige isso).

É aí que entra o verdadeiro problema da atualização, se o site usa um banco de dados maciço com algo como sobipro, k2 ou construtor de conteúdo, ou apenas muitos artigos/módulos, a atualização pode falhar muito mais facilmente. Esses também não podem ser removidos, desativados ou desinstalados (por exemplo, mais de 4000 itens seriam perdidos com uma desinstalação; nesse momento, é possível refazer o site e atualizar).

Existe algum plano para melhorar a atualização de um clique para 2,5 a 3.x para melhor acomodar a EoL? (como posts ou blogs) Pergunta estranha, mas eu sinto com quantos sites 2.5 existem por aí que não conseguem atualizá-lo, pode valer muito a pena.

15
Jordan Ramstad

atualização com "um clique" funciona muito bem no Joomla! 2,5 Núcleo.

Mas seu site pode ter vários modelos ou extensões para atualização também.

Também estou planejando uma migração de "junho" do site principal. Este é o meu plano:

  • Faça backup do site principal e crie um novo site de teste
  • Revise os requisitos do sistema para o Joomla 3.xe verifique se o ambiente do servidor atende a esses requisitos.
  • Instale e personalize um novo Joomla! 2,5/3 modelo compatível
  • Instale e personalize todos os Joomla! 2.5/3 extensões compatíveis
  • Se alguma extensão não tiver uma versão compatível com J3, ela deverá ser substituída por uma nova extensão .... E os dados deverão ser migrados (pior cenário)
  • NOTE : As etapas anteriores podem ser executadas off-line, testadas e, no final, você pode implementá-las em sua versão atual. Joomla! Site 2.5 para reduzir o risco de migração de um dia.
  • Atualize seu site de desenvolvimento com o site ativo mais recente
  • Etapa final: atualização com "um clique" para o Joomla! 3 no site de desenvolvimento
  • Teste e verifique tudo até que funcione
  • Migrar o site ativo (ou restaurar a captura instantânea mais recente do site de desenvolvimento em uma nova hospedagem .... apenas no caso de algo dar errado e você precisar reativar o site J2.5)
  • SUCESSO
11
Anibal

Para atualizações de 2,5 para 3,3, tive mais sorte fazendo uma atualização manual também. Para as versões, irei até 2.5.20-> 3.0.3-> 3.1.6-> 3.2.4-> 3.3.0.

Este é o processo completo:

  1. Baixe todas essas versões e descompacte na máquina local (aqui está um bom recurso: http://www.whitefirdesign.com/resources/joomla-release-archive.html )
  2. Backup usando o Akeeba
  3. Criar site clone em subpasta usando o Akeeba Kickstart (criar/usar novo banco de dados)
  4. No back-end do site, desinstale as extensões "problem" (veja a parte inferior da postagem)
  5. No FTP, carregue todos os arquivos de uma nova versão do Joomla, exceto a pasta/installation /.
  6. No back-end do site, vá para EXTENSIONS-> EXTENSIONS MANAGER-> DATABASE, e pressione FIX
  7. Em seguida, vá para EXTENSÕES-> GERENTE DE EXTENSÕES-> DESCUBRA, clique em descobrir e instalar para qualquer coisa que encontrar
  8. Vá para o Gerenciador de ACL (se você não tiver, eu sugiro) e corrija os problemas que encontrar. http://aclmanager.net
  9. Repita o processo com a próxima versão do Joomla

Depois de chegar à versão mais recente:

  1. Reinstale as extensões "problem"
  2. Nova versão de backup
  3. Site de teste para problemas
  4. Mover o site original para a subpasta
  5. Mover novo site para a raiz para entrar no ar

Todo esse processo leva muito tempo por causa do tempo de upload das versões completas, mas economiza dores de cabeça.

Para extensões de problemas, essas são apenas as que causaram problemas durante as atualizações para mim. Minha hipótese é que o pacote de instalação realmente possui versões diferentes para o J2.5 vs o J3.3, por isso fica confuso quando você atualiza. Se alguém encontrou outras pessoas, entre em contato.

  • Extensões NoNumbers (NN Manager, Cache Cleaner, Adv Module Manager, Módulos em Qualquer Lugar, etc)

Essas extensões podem causar problemas se não estiver usando a versão mais recente:

  • RSForm
  • JW AllVideos
  • RokBox
  • RSForm
  • Marcadores sociais
  • XMap
4
YellowWebMonkey

Não consegui atualizar o diretório de 2.5.7 para 3.2.0. Eu encontrei vários erros durante essas atualizações, às vezes incapazes de atualizar.

O caminho de atualização que eu tive que seguir como:

2.5.7 → 3.0.1 → 3.1.5 → 3.2.0

Desde então, tenho conseguido atualizar normalmente. Estou executando o 3.2.2 e planejando atualizar para o 3.3 em breve.

3
ContextSwitch

Para responder à pergunta principal:

Quão bem a atualização de "um clique" vai melhorar antes da EoL do Joomla! 2,5?

Não há planos para melhorá-lo. Está funcionando sem problemas para o núcleo. O modelo precisará ser substituído devido à alteração na saída da extensão. As outras extensões precisam ser verificadas manualmente, depende de como elas são construídas. É possível escrever extensões que funcionem em 2.5.15+ e 3.x com a mesma base de código. Mas é preciso verificar isso tentando ou entrando em contato com o desenvolvedor (ou lendo as perguntas frequentes).

A única coisa que pode ser aprimorada no 2.5 é adicionar uma verificação de compatibilidade pré-atualização. Houve algum trabalho feito para isso, mas ele parou. Alguém da comunidade teria que pegar isso e acabar com isso.

2
Bakual

Aqui estão algumas informações úteis que encontrei sobre a atualização.

Por um lado, se o site foi originalmente na versão 1.6, foi atualizado para 2.5 e, mesmo nas versões mais recentes da 2.5, todas as extensões ainda funcionarão. No entanto, a atualização para 3.x requer uma reinstalação. Isso ocorre porque as diferenças na área "atualização" significam que, se fosse 1.6, o servidor de atualizações não leria as atualizações corretamente; portanto, se fosse um componente 1.6, pelo menos na maioria dos casos (eu já vi isso no DJ Image Slider e BreezingForms) não serão atualizados após a atualização para 2.5.

Portanto, uma atualização manual dessas extensões é necessária em algum momento de sua vida útil na versão 2.5. Acredito que, dependendo da extensão, também possa haver problemas com a atualização normal do sql, mas apenas algo para estar ciente.

Às vezes, as extensões podem ser renomeadas ou "renovadas", o que fará com que o Joomla às vezes o leia como um novo componente, levando a várias entradas do mesmo componente, antigas e novas. Se você desinstalar uma, ela ainda usará as mesmas tabelas de banco de dados, e as limpará se você já as instalou.

Idéia: Então, uma coisa que eu acho que seria útil nesse caso é um complemento ao gerenciador de extensões para verificar se há extensões destinadas a versões mais antigas, para torná-las facilmente visíveis, isso pode ser feito olhando para a última atualização "date" e foi antes de uma possível mudança no Joomla se a versão atual já passou dessa versão.

De qualquer forma, no caso de um site que vai de 1,6 para 2,5 e depois para 3.x a qualquer momento, pode forçar uma reinstalação que, portanto, limparia os dados.

Outra idéia: Se uma "reinstalação" for adicionada ao lado da atualização, use o controle da versão mais antiga e seu servidor de atualização ou um URL/upload personalizado para desinstalar basicamente o componente sem limpar os dados. Em seguida, reinstale-o enquanto estiver usando as atualizações do sql para atualizar as tabelas do banco de dados seria extremamente útil.

Estou usando um site que era originalmente 1.6, pois mostraria esses problemas com mais frequência. Isso também pode acontecer com sites iniciados no 2.5.

Isso explica muitos problemas que podem surgir de extensões que talvez nunca tenham sido atualizadas para adicionar compatibilidade ao 3.x. Os plugins são os piores, pois mesmo no painel de administração, um erro naqueles pode tornar o painel de administração inutilizável.

Ainda outra idéia: O gerenciador de atualizações do Joomla pode desativar automaticamente todos os plugins de terceiros, exceto alguns (como akeeba, pois rastreia atualizações) e atualiza. Depois de reativar todos os plugins novamente, mas "verifica" os plugins do sistema quanto a erros. O que quero dizer é que ele dispara automaticamente vários eventos com uma tentativa/captura para ver se há um erro, se há, desativa e notifica.

Agora, tudo isso não assume nenhum problema central, o que normalmente não deveria acontecer em uma atualização.

As idéias que eu postei acima são para a equipe de desenvolvimento, o restante é uma boa informação para qualquer um que esteja atualizando. As idéias que eu criei devem ser capazes de permitir atualizações sem desinstalar/desabilitar extensões primeiro que possam potencialmente adicione muito mais trabalho ao processo. Com algumas adições ao já excelente atualizador, até atualizações automáticas completas (como o wordpress) podem ser possíveis no futuro.

2
Jordan Ramstad

O procedimento que eu uso evoluiu em cerca de 40 mini-migrações diversas do Joomla 2.5 a 3.x. Não é exatamente "um clique", mas ajuda a evitar as armadilhas mais comuns. A maioria dos sites que eu cuido usa modelos RocketTheme e existem versões equivalentes ao Joomla 3.x dos modelos Joomla 2.5 que reduziram os problemas de migração de modelos para mim, mas sua milhagem pode variar.

  1. Verifique se o ambiente de hospedagem é adequado para o Joomla 3.x

  2. Execute o backup primeiro!

  3. Desinstale quaisquer extensões que não sejam compatíveis com o Joomla 3.x

  4. Atualize para o Joomla 2.5.28 se ainda não estiver no 2.5.28 e atualize todas as extensões de terceiros para as versões mais recentes disponíveis do Joomla 2.5

  5. Desative o plug-in "Sistema - Lembrar-me"

  6. Desative o plug-in "Sistema - Backup em atualização" se o Akeeba Backup estiver instalado

  7. Na Configuração Global, defina o Relatório de Erros como "Desenvolvimento" (para que os erros sejam visíveis após a migração - se você perder esta etapa, poderá usar o FTP etc para baixar o configuration.php, edite-o para ativar as mensagens e faça o upload da versão atualizada via FTP etc, o que é uma dor)

  8. Alterar componentes -> Atualização do Joomla -> Opções para "Suporte a curto prazo"

  9. Em Componentes -> Atualização do Joomla, clique em "Instalar a atualização" para atualizar de 2.5.x para 3.5.1, 3.5.1 para 3.6.5 e 3.6.5 para a versão mais recente. Limpe o cache do Joomla e limpe o cache em Extensões -> Gerenciador de extensões -> Atualização e tente novamente se a atualização não for oferecida. Pode ser necessário autenticar novamente uma ou duas vezes, conforme as atualizações de token de sessão são executadas

  10. Alterar componentes -> Atualização do Joomla -> Opções -> Atualizar canal para "Padrão" se ainda não estiver redefinido para "Padrão"

  11. Reinstale as extensões mais recentes do Joomla 3.x na parte superior de todas as extensões instaladas, especialmente ChronoForms e quaisquer ações ChronoForms, se você tiver alguma delas instalada

  12. Limpe o cache do Joomla e o cache do seu navegador

  13. Na configuração global, defina o Relatório de erros novamente como "Nenhum".

  14. Reative o plug-in "Sistema - Backup em atualização" se o Akeeba Backup estiver instalado

  15. Reative o plug-in "Sistema - Lembrar-me"

  16. Desative o plug-in "System - Joomla! Update Notification" para desativar as notificações de atualização do Joomla (opcional)

  17. Remova os modelos do Joomla 2.5 (atômico, beez5, beez_20, bluestork)

  18. Ative o controle de versão em Conteúdo -> Artigos -> Opções -> Editar layout, se apropriado (o controle de versão está desativado por padrão)

  19. Desative "Permitir registro do usuário" em Usuários -> Gerenciar -> Opções -> Opções do usuário, se apropriado (isso foi ativado como padrão no Joomla 2.5)

A Etapa 11 é importante para permitir que os scripts de instalação executem etapas específicas do Joomla 3 que podem não ter sido executadas quando foram originalmente instaladas no Joomla 2.5.

Lembre-se de atualizar a versão PHP versão, se apropriado. PHP 5.3 é o fim da vida útil e PHP 5.6 ou PHP 7.0 ou posterior é uma escolha melhor para o Joomla 3.x agora.

1
Neil Robertson

Acho que há tantas coisas a considerar na atualização que simplesmente não podem ser consideradas um processo de "um clique".

Versões PHP são a primeira coisa a considerar. Versões do Joomla também ... sempre atualize para a versão final em qualquer árvore antes de subir a escada para a próxima. Use o Akeeba CMS Updater para selecionar as atualizações que você deseja aplicar e de qual filial.

As extensões são onde realmente fica peludo.

O uso de uma extensão como SP Transfer pode reduzir problemas ao criar um site secundário que pode ser pré-instalado na nova versão com todos os componentes instalados para essa versão e depois extrair todos os dados necessários do banco de dados.

Esse processo não é para o usuário comum em geral.

Na maioria das vezes, encontro algum nível de problema na tabela de ativos e geralmente preciso empregar o diagnóstico do Gerenciador de ACL para corrigir itens órfãos ou ausentes na tabela.

1
BodgeIT