ti-enxame.com

Quando mudar para uma nova versão principal?

Com a nova estratégia de desenvolvimento, não haverá versão chamada LTS antecipadamente. Com as informações atualmente publicadas, o 3.4 substituirá o 3.5 anunciado. Supondo que haja planos para 4.0,4.1,4.2,4.3,4.4 a que horas os sites devem ser migrados para qual versão.

11
sovainfo

Há algumas coisas a considerar ao planejar migrações entre as principais versões. Um dos principais deve ser o final do suporte ou a data da EOL para a versão que você está usando agora; se isso estiver próximo, você deve planejar sua mudança.

Para sites estabelecidos, sugiro olhar para os recursos disponíveis. A nova versão tem algo que você precisa em breve? Nesse caso, comece a planejar sua migração. Se o seu site estiver funcionando bem e não precisar dos recursos mais recentes, você poderá permanecer na versão atual enquanto ainda houver suporte.

Se você estiver migrando, como é o suporte a extensões? As extensões que você usa têm uma versão compatível para a versão para a qual você está migrando? Nesse caso, isso simplifica bastante as coisas, mas se não o fizerem, quanto esforço será necessário para substituir seus recursos por outra coisa?

Finalmente, cada versão marcada como estável deve ser adequada para a criação, mas pessoalmente eu seria um pouco mais cautelosa ao usar uma versão X.0 ou mesmo X.1, pois essas são tipicamente mais propensas a ter erros, devido ao escopo de mudança que pode entrar em uma versão principal do X.0. Pessoalmente, acho que os lançamentos X.2 ou X.3 são quando você começa a ver uma série de lançamentos amadurecer a ponto de estar pronta para uso importante.

6
Michael

A partir do Joomla! 3.4 todas as versões serão estáveis ​​e terão suporte por pelo menos dois anos, a menos que a nova versão secundária seja lançada. Se isso acontecer, a versão secundária anterior não será suportada e a versão atual será suportada por pelo menos dois anos. Portanto, se você estiver planejando migrar para a série 3.x, estará seguro a partir da v3.4.

O mesmo se aplica à série 4.x - 4.0 também será estável e terá suporte por pelo menos dois anos, a menos que a nova versão secundária seja lançada (por exemplo, 4.1). Portanto, você pode migrar para quaisquer versões secundárias da série 4.x. Mas lembre-se de que toda versão principal tem alterações incompatíveis com versões anteriores! Portanto, essa migração deve ser planejada com muito cuidado.

Obviamente, você não deve migrar para versões BETA ou RC, porque são apenas para fins de teste.

1
Dmitry Rekun

No meu entendimento, a partir do 3.4, você sempre deve usar a versão mais recente, pois ela receberá suporte por 2 anos após a liberação e o suporte para versões mais antigas (3.3, ...) será descontinuado. Todas as versões de uma série (3.x) são compatíveis com versões anteriores, portanto, uma atualização geralmente não deve ser problema.

A nova série 4.x quebrará a compatibilidade com versões anteriores e você só deve atualizar se quiser usar os novos recursos.

0
fruppel
  1. Se você estiver iniciando o desenvolvimento, use a versão principal mais recente disponível (use a série 4 quando disponível)
  2. Quando uma nova versão secundária (3.4) é lançada, aguarde o tempo em que sua versão atual (3.3) é suportada. No período em que a nova versão deve ter recebido correções críticas de erros. Agora, seu site pode ser atualizado com segurança.

Dica: Sempre mantenha um site de teste com a mesma configuração do servidor, para testá-lo primeiro e, em seguida, use a versão.

0
Shyam