ti-enxame.com

Migrar usuários, permissões, acesso, grupos e conteúdo de 1.6 para 3.3.X

Eu tenho que atualizar uma instalação do joomla da 1.6 para uma nova versão, espero que 3.3.X. Tenho andado brincando com o processo de atualização passo a passo para mudar de versão para versão. Até agora, não está indo bem.

Como alternativa, eu estava pensando em simplesmente fazer uma nova instalação da nova versão do Joomla 3.3, se houvesse alguma maneira de migrar o conteúdo da antiga instalação 1.6.

Alguém sabe uma maneira de fazer isso?

Instalar as novas versões de componentes e extensões não seria difícil, mas eu precisaria mover todos os usuários, grupos, níveis de acesso e todos os artigos e menus. É claro que os artigos e menus precisariam manter o acesso e os locais corretos para que tudo funcionasse. Também não quero ter que re-configurar todos os usuários.

Obrigado por qualquer ajuda!

3
jeffery_the_wind

Tente novamente uma migração passo a passo:

Faça um backup primeiro e tente o seguinte:

  1. Siga estas instruções para atualizar o Joomla 1.6.x para o Joomla 2.5.x - http://www.ostraining.com/blog/joomla/upgrade-joomla-16-to-25/
  2. Certifique-se de que todos os componentes, plugins e modelos estejam prontos para o Joomla 3.3
  3. Desative o plug-in rememberme.
  4. Então vá para o Joomla! Atualize no menu Componentes e clique no botão Opções
  5. Altere a configuração do servidor de atualização para suporte a curto prazo e salve
  6. Então você vê a atualização mais recente do Joomla e pode processar da maneira usual.
  7. Ative seu plug-in rememberme.
3
Joomla Agency

Você primeiro precisa garantir que está executando o Joomla 1.6.5, que é o mais recente da série 1.6. Depois de concluído, vá para Extensões (menu superior) >> Atualização >> Limpar cache >> Localizar atualizações.

A atualização usando o recurso de atualização com 1 clique, conforme descrito acima, atualizará automaticamente suas tabelas de banco de dados, código e extensões de núcleo. Portanto, você não precisa se preocupar com a migração manual de usuários, permissões etc.

No entanto, você pode precisar instalar versões mais atualizadas de extensões e modelos de terceiros que você instalou, pois existem algumas alterações fundamentais na API desde o Joomla 1.6.

Espero que isto ajude

2
Lodder